1. Home
  2. Docs
  3. Documentation
  4. Error Messages
  5. Failed to parse supported auth schemes: The operation identifier is not valid.

Failed to parse supported auth schemes: The operation identifier is not valid.

VersionSQL’s attempt to secure a connection via OAuth was blocked by an atypical response from Azure DevOps. This rare error may be triggered by unusual user account permissions. As a workaround, use a Personal Access Token (PAT) with Code: Read & Write permissions:

  1. Navigate to Azure DevOps > User Settings > Personal Access Tokens.
  2. Create a new token with Code: Read & Write permissions.
  3. Clear existing credentials from your VersionSQL connection and try connecting again.
  4. Close the OAuth dialog when it appears and input your new PAT when prompted.

Note: If you are already using a PAT and see this error, ensure the token has not expired.

Was this article helpful to you? Yes No

How can we help?